图片批量下载

使用易语言的人都知道,易语言IDE中的代码中有表格和流程线,不是一般的文本代码。把代码复制出来后再粘贴到编辑器中,就是纯文本的代码,跟IDE中相差十万八千里,而且非常不容易阅读。于是有不少人做了一些在网页上体现易语言IDE中原来样式的工具,用到了table表格,流程线用图片作为背景。虽然这样看起来跟IDE中几乎一模一样,但是却不能直接复制到IDE中使用,必须把原始代码加进去,通过点击按钮或链接来复制原始代码。

我个人认为,代码贴出来就是为了交流的,要体现出易读、易复制的特性,不能带上太多的附件。对于易语言这种特殊形式的代码,不需要完全按照它原来的样式来表现, 只要体现出那个意思就行了。这几天修改了以前做的一个易语言代码高亮工具,用CSS控制表格、流程线样式,做了一个还算过得去的模块。效果如下:

  1. .子程序 _启动子程序,整数型,,本子程序在程序启动后最先执行 
  2. .局部变量 数字,整数型 
  3. .局部变量 文本,文本型 
  4. .局部变量 数组,文本型,,"0" 
  5. .局部变量 m,整数型 
  6. .局部变量 i,整数型 
  7. 置随机数种子 (取启动时间 ())
  8. 数字 = 取随机数 (0, 10000)
  9. 数组 = { “个”, “十”, “百”, “千”, “万” }
  10. m = 取文本长度 (到文本 (数字))
  11. .计次循环首 (m, i)
  12.  .如果真 (i > 1)
  13.     文本 = “, ” + 文本
  14.     .如果真结束
  15.   文本 = 数组 [i] + “位:”取文本中间 (到文本 (数字), m - i + 1, 1) + 文本
  16. .计次循环尾 ()
  17. 调试输出 (数字, 文本)
  18.   
  19. 返回 (0) ' 可以根据您的需要返回任意数值
  20. #鸿言_易代码格式化模块 HyStudio.Net

下载地址:鸿言_易代码格式化模块.zip

特点:

1、样式与html代码分离,减小格式化后的体积;

2、样式是独立出来的,可以自己修改高亮颜色以及列表形式;

3、 显示行号,也可以在css中修改行号的显示和隐藏;

4、可以选择显示或隐藏复制出来的版本号和支持库声明;

5、可以直接复制到易语言IDE中使用。

需要注意的几点:

1、 你知道的,这是易语言模块,必须在易语言中使用;

2、请特别注意:要把样式代码加入到CSS文件中或者对应的网页头部,否则无法显示效果;

3、 格式化之前的原始代码最好是从IDE中直接复制出来的,以免导致格式化出现错位的现象;

4、子程序等表格头可能会被超长的备注文字撑开,可以在CSS中修改表头长度;

5、 “.如果结束”、“.判断结束”等语句是通过设置颜色隐藏的,如果网页设置了阴影样式,会导致其显示;

6、复制到IDE中时要把代码选择完整,不能丢失 “.如果结束”等隐藏的行。

另外格式化后的代码底部有我的版权信息,你可以选择保留或者隐藏该信息,但不能换成其他版权信息。

附样式代码:

  1. .e_c0 {display:inline-blockwidth:6pxcolor:#FAFAFAfont-size:6px;} /*圆点*/
  2. .e_c1 {color:#104E8B;} /*声明*/
  3. .e_c2 {color:#0000FF;} /*类型*/
  4. .e_c3 {color:#AA0000;} /*方法*/
  5. .e_c4 {color:#EE00EE;} /*字串*/
  6. .e_c5 {color:#00A800;} /*注释*/
  7. .e_c6 {color:#FF0000;} /*数字*/
  8. .e_c7 {color:#5830E0;} /*属性*/
  9. .e_c8 {color:#0000A0;} /*名称*/
  10. .e_c9 {color:#000000;} /*常规*/
  11. .e_ca {display:inline-blockwidth:6pxcolor:#E4EDE4font-size:6px;} /*子程序表逗号*/
  12. .e_cb {display:inline-blockwidth:6pxcolor:#F4F7F4font-size:6px;} /*参数变量表逗号*/
  13. .e_cc {padding:0 2px 0 10pxborder-left:1px dotted #A6A6A6color:#00A800;} /*表中备注*/
  14. .e_s0 {display:inline-blockwidth:18pxborder-left:1px dashed #A6A6A6;} /*标志前缩进*/
  15. .e_s1 {display:inline-blockwidth:24pxborder-left:1px dashed #A6A6A6;} /*语句前缩进*/
  16. .e_s2 {display:inline-blockwidth:24pxborder-top:0px dashed #A6A6A6;}  /*标志尾语句前缩进*/
  17. .e_s3 {color:#FAFAFA;} /*标志尾语句*/
  18. .e_s4 {display:inline-blockwidth:460pxline-height:20pxpadding:3px 10px 0 0; background-color:#E4EDE4border-top:1px solid greenwhite-space:nowrap;} /*子程序等表格*/
  19. .e_s5 {display:inline-blockwidth:460pxline-height:20pxpadding:0 10px 0 0; background-color:#F0F7F0white-space:nowrap;} /*参数、变量等表格*/
  20. .e_url {text-decoration:none;} /*网站链接*/
  21. .e_div {font-family:"Courier New",Courier,mono; font-size:12pxbackground-color:#FAFAFAborder:1px solid #D1D7DCwidth:100%; min-width:580pxoverflow:automargin:0;} /*主体*/
  22. .e_div ol {padding:10px 10px 2px 2pxcolor:#2B91AF;} /*主体列表*/
  23. .e_div ol li {border-left:1px solid #D1D7DCpadding-left:24pxline-height:20px;} /*主体行*/
  24. .e_div ol li.e_ht {border-left:1px solid #D1D7DCpadding-left:18pxline-height:20px;} /*表头行*/
  25. .e_div ol li.e_hb {border-left:1px solid #D1D7DCpadding-left:18pxline-height:20px;} /*标志头行*/
  26. .e_from {list-style-type:nonetext-align:rightcolor:#FAFAFApadding:10px 0 0 0;} /*末尾版权声明*/

转载请注明出处: http://www.hystudio.net/173.html | 鸿言软件工作室

人际关系管理

您可能还会对这些文章感兴趣!

成长管理

我来说说

(必须)

(必须,保密)

(必须,验证码)

飘过的鸟,请留下一点东西,比如叫声...
取消
点击发消息