图片批量下载

这是我用易语言编的一个揭示赌博机本质的简单程序,本程序的目的是劝那些玩赌博机的人立即戒赌,而不是提供赌博软件。

很多人沉湎于赌博机,经常输得七荤八素。究其原因,就是因为赌博机是由程序运行的,而程序则是人为编写的,编写赌博程序的人要给购买赌博机的人留下修改参数的接口,就是这个可以任意修改参数的接口让那些赌博的人永远是输远大于赢。道理很简单,老板买赌博机就是为了赚钱,他会为了所谓“公平”从而把金钱拒之门外吗?看看这个程序就知道了,赌博程序有很多手段可以做,不但赌博机可以这样,其他什么网络赌博等等都可能被人操纵!所以奉劝那些赌博的人一句——赶紧戒赌吧!

该程序升级了一下,可以运行测试,请查看:http://www.hystudio.net/?p=177

  1. .程序集 程序集1 
  2. .程序集变量 输赢,整数型 
  3. .程序集变量 赚次,整数型,,"0" 
  4. .程序集变量 玩次,整数型 
  5. .程序集变量 轮次,整数型 
  6. .程序集变量 首赚,整数型 
  7.   
  8. .子程序 _窗口1_创建完毕 
  9. 轮次 = 10
  10. 首赚 = 2 ' 刚开始让你赚的次数
  11. ' ==================================== 我做的手脚之一,让你一开始先赚赚!
  12.   
  13. .子程序 _按钮1_被单击 
  14. .局部变量 是否,逻辑型 
  15. .局部变量 i 
  16. 标签1.标题“点击看输赢”
  17. 标签1.文本颜色#灰绿
  18.   
  19. .如果真 (玩次 = 0 玩次 % 轮次 = 0)
  20.   随机赚 (4) ' 一个轮次内让你赚的次数
  21.   .如果真结束
  22. ' ==================================== 我做的手脚之二,你输赢的次数已经由我控制!
  23.   
  24. 玩次 = 玩次 + 1
  25. .计次循环首 (取数组成员数 (赚次), i)
  26.  .如果真 (玩次 % 轮次 = 赚次 [i] 轮次 = 赚次 [i] 玩次 % 轮次 = 0)
  27.     是否 = ' 赚
  28.     跳出循环 ()
  29.     .如果真结束
  30. .计次循环尾 ()
  31.   
  32. .如果 (是否)
  33.    (, 随机率 (10, 200)) ' 当你赚的时候给你的赔率范围
  34. .否则
  35.    (, 随机率 (30, 300)) ' 当你赔的时候给我的赔率范围
  36.   .如果结束
  37. ' ==================================== 我做的手脚之三,你输赢的多少早就在我的掌握中!
  38.   
  39. .子程序 随机赚,,,在一个轮次内根据次数随机获取让你赚的次序,不让你觉察到我做了手脚 
  40. .参数 次数,整数型,,每轮次赚几次,根据我的需要设置 
  41. .局部变量 f,逻辑型 
  42. .局部变量 i 
  43. .局部变量 j 
  44. .局部变量 k 
  45. 清除数组 (赚次)
  46. .如果真 (玩次 = 0 首赚 > 0)
  47.  .计次循环首 (首赚, i)
  48.     加入成员 (赚次, i)
  49.  .计次循环尾 ()
  50.   .如果真结束
  51. i = 0
  52. 置随机数种子 (取启动时间 ())
  53. .判断循环首 (i < 次数)
  54.   f =
  55.   i = i + 1
  56.   k = 取随机数 (1, 轮次)
  57.  .计次循环首 (取数组成员数 (赚次), j)
  58.    .如果真 (赚次 [j] = k)
  59.       f =
  60.       i = i - 1
  61.       跳出循环 ()
  62.       .如果真结束
  63.  .计次循环尾 ()
  64.  .如果真 (f)
  65.     加入成员 (赚次, k)
  66.     .如果真结束
  67. .判断循环尾 ()
  68.   
  69. 数组排序 (赚次, )
  70. 调试输出 (赚次)
  71.   
  72. .子程序 随机率,双精度小数型,,根据赚赔设置不同的赔率,根据我的需要 
  73. .参数 低值,整数型 
  74. .参数 高值,整数型 
  75. .局部变量 结果,双精度小数型 
  76. 置随机数种子 (取启动时间 ())
  77. 结果 = 取随机数 (低值, 高值) ÷ 100 ' 从低到高随机获取赔率,不让你觉察到我做了手脚
  78. 返回 (结果)
  79.   
  80. .子程序 ,,,你所要做的事情就是这个“赌”,但是程序在“赌”的背后还做了很多你看不到的事情 
  81. .参数 赚赔,逻辑型,,根据我的需要让你赚还是赔,一个轮次内让你赚几次 
  82. .参数 赔率,双精度小数型,,根据我的需要设置的赔率,你赢的时候赔率小,输的时候赔率大 
  83. .局部变量 结果,整数型 
  84. 结果 = 到整数 (编辑框1.内容)
  85. 结果 = 结果 × 赔率
  86. .如果真 (赚赔 = )
  87.   结果 = -结果
  88.   .如果真结束
  89. 编辑框2.内容到文本 (结果)
  90. .如果 (结果 < 0)
  91.   编辑框2.文本颜色#红色
  92. .否则
  93.   编辑框2.文本颜色#蓝色
  94.   .如果结束
  95. 输赢 = 输赢 + 结果
  96.   
  97. .子程序 _按钮2_被单击 
  98. 玩次 = 0
  99. 输赢 = 0
  100. 编辑框1.内容“1000”
  101. 编辑框2.内容“”
  102. 标签1.标题“点击看输赢”
  103. 标签1.文本颜色#灰绿
  104.   
  105. .子程序 _按钮1_按下某键,逻辑型 
  106. .参数 键代码,整数型 
  107. .参数 功能键状态,整数型 
  108. .如果真 (键代码 = #回车键)
  109.   _按钮1_被单击 ()
  110.   .如果真结束
  111. .子程序 _标签1_鼠标左键被放开,逻辑型 
  112. .参数 横向位置,整数型 
  113. .参数 纵向位置,整数型 
  114. .参数 功能键状态,整数型 
  115. .如果 (输赢 < 0)
  116.   标签1.标题“输了: ”到文本 (取绝对值 (输赢)) + “元”
  117.   标签1.文本颜色#红色
  118. .否则
  119.   标签1.标题“赢了: ”到文本 (输赢) + “元”
  120.   标签1.文本颜色#蓝色
  121.   .如果结束
  122. 标签1.标题“你总共玩了: ”到文本 (玩次) + “次,” + 标签1.标题
  123. #鸿言_易代码格式化模块 HyStudio.Net

转载请注明出处: http://www.hystudio.net/171.html | 鸿言软件工作室

人际关系管理

您可能还会对这些文章感兴趣!

成长管理
我要留言

2访客评论

  1. 如果能出个wp的插件就好了 :roll:

    yulon2011-07-29 18:33 [回复]
    • 你指的是易代码格式化模块吧。目前还存在一些缺陷,如果直接做成插件可能会导致格式化后的代码混乱,不如在本地格式化并检查正常后再粘贴到内容里面,反正也不费事。

      渺孤鸿2011-07-29 19:15 [回复]

我来说说

(必须)

(必须,保密)

(必须,验证码)

飘过的鸟,请留下一点东西,比如叫声...
取消
点击发消息